gmth.net
当前位置:首页 >> 如何用Apxs模块编译安装php5.2 >>

如何用Apxs模块编译安装php5.2

让Apache服务器能够支持PHP。 如果编译安装时不加--options --with -apxs2参数,即使你的电脑上安装了Apache和PHP,通过Apache是不能访问PHP页面的,因为Apache本身只支持静态html页面。加入此参数,则能通过Apache访问PHP页面了。

让Apache服务器能够支持PHP。 如果编译安装时不加--options --with -apxs2参数,即使你的电脑上安装了Apache和PHP,通过Apache是不能访问PHP页面的,因为Apache本身只支持静态html页面。加入此参数,则能通过Apache访问PHP页面了。

你装php的时候没有选择关联么??没有遇到过这种情况.你重新编译一下php吧.--with-apxs=/apache/bin/apxs2

with-gd=/usr/local/gd2/ 改成with-gd 使用默认系统库看看

其实何必呢? 你装一个WAMP 里面都有了, 内嵌mysql , apache 现在多流行啊,, 非得那么个版本才能开发? 强烈介意啊 楼主!

因为你的系统里面是Apache2,那么参数中的下面部分: --with-apxs=/usr/local/apache/bin/apxs 应该修改为: --with-apxs2=/usr/local/apache/bin/apxs

如果你把/bin /lib /config /logs /webapps等一系列目录看成是tomcat应用整体的话yum安装(其实是rpm的安装)一般会把这个整体拆分,比如tomcat的bin目录内容拷贝到/usr/bin目录内。lib目录内容拷贝到/usr/lib内。config目录拷贝到/etc/tomcat内...

先建目录 mkdir -p /usr/local/php

安装的时候需要制定 apxs 路径 具体参数是--with-apxs2= apxs 是apache提供的模块安装工具,php作为apache的一个模块加载进来,就必须指定他的路径。 希望能够帮助到你,有问题可以随时私信交流。

把服务器重启一下就Ok了。

网站首页 | 网站地图
All rights reserved Powered by www.gmth.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com